POS charge to reservation error

Post here if you think you have found a bug in hoteldruid or error in its documentation.

Moderator: marco

Post Reply
pwsoe
Posts: 1
Joined: Fri Apr 21, 2017 5:20 pm

POS charge to reservation error

Post by pwsoe » Sun Apr 23, 2017 5:37 pm

Hello,

I am trialling HotelDruid 2.2.0 on an Ubuntu 16.04 server.

I encountered an error when I tried to insert a POS item on a reservation.

An item (water bottle) was added as an extra cost item with these characteristics: Drinking water bottle (sml)
(Beverages) | single, fixed | 350 Kyats | Do not display; group; ask by how much multiply

If I added that item on the reservation page (Modify or Delete reservation), it would be fine. However if I did, Insert > Point of Sale > On Reservation, I would get the following error message and it won't insert the cost to the reservation:

ERROR IN: insert into costiprenota2017 (idcostiprenota,idprenota,tipo,nome,valore,associasett,settimane,moltiplica,letto,idntariffe,varmoltiplica,varnumsett,varperiodipermessi,varbeniinv,varappincompatibili,vartariffeassociate,vartariffeincomp,datainserimento,hostinserimento,utente_inserimento) values ('4','1','uf','Drinking water bottle (sml)','350','','','2','n','','cx0,','c','','','','','','2017-04-21 16:17:15','192.168.1.101','1')
1366: Incorrect integer value: '' for column 'idntariffe' at row 1

I saw that someone had the same issue - http://www.hoteldruid.com/forums/viewto ... c08c#p4088 (I used Google translate to view the contents btw.)

I don't see any such error when I tried the POS function on HotelDruid demo site.

Please let me know how I can fix that.

Thank you.

marco
Posts: 1257
Joined: Tue Jul 05, 2005 6:00 pm
Location: Roma, Italia
Contact:

Re: POS charge to reservation error

Post by marco » Fri Jul 28, 2017 1:45 am

Hello,
this should have been solved in version 2.2.1.

Regards,
Marco
Problems installing, configuring, upgrading?
Try the easiest way to use HotelDruid:
https://www.digitaldruid.net/hosted/index.php

Post Reply